NETCONF、YANG および Zero-Touch Provisioning
OcNOS は、モデル駆動型の設定基盤を提供します。SSH/TLS 上の NETCONF、OpenConfig とネイティブ YANG、commit/rollback に対応する candidate データストア、そして DHCP リースで新しいルーターを運用状態まで導く Zero-Touch Provisioning です。
Day-0ゼロタッチプロビジョニングフロー
工場出荷状態の OcNOS ルーターが起動し、DHCP リースを要求し、イメージを取得してから設定を取得し、運用状態に到達します。現地にオペレーターは不要です。

モデル駆動型のコンフィグレーションが重要な理由
CLIスクリプトは合成できず、ロールバックできず、入力をスキーマに照らして検証もできません。 NETCONF + YANG は、型付きでトランザクショナルな設定基盤を提供します。candidate をプッシュし、検証し、コミットするか、いずれかの leaf が拒否された場合は変更を破棄します。OcNOS は、OcNOS 固有のパラメーター向けに OpenConfig モデルと IP Infusion ネイティブモデルを公開します。Zero-Touch Provisioning と組み合わせることで、新しいルーターは現地にオペレーターがいなくても運用状態に到達します。
OcNOS の NETCONF、YANG、ZTP の実装
SSH + TLS トランスポート
RFC 6241 NETCONF プロトコル、SSH (RFC 6242) および TLS (RFC 7589) 上で動作、Get / Get-Config / Edit-Config / Commit / Validate / Lock / Discard-Changes の全 RPC をサポート。
候補設定+コミット/ロールバック
NETCONF による candidate データストア。CLI では commit confirmed と、コミット履歴から以前のコミットへの commit-rollback。
Day-0 プロビジョニング
IPv4 または IPv6 による DHCP 駆動のブート:イメージを取得してインストールし、再起動してから設定を取得します。
OcNOSオートメーションで得られるもの
- 運用上のロールバック。 コミット履歴を有効にすると、変更に問題が生じた場合に CLI の commit-rollback コマンドで以前のコミットに戻せます。
モデル駆動型のオペレーションスタックを立ち上げますか?
技術デモをリクエスト →よくあるご質問
OcNOS は NETCONF を介してどの YANG モデルに対応していますか。
OcNOS は設定のロールバックをサポートしていますか。
OcNOSではZero-Touch Provisioningはどのように動作しますか。
さらに詳しく。資料をお持ち帰りください。
このページよりもさらに踏み込んだ、簡潔で技術的な 2 つのダウンロード資料。OcNOS-SP データシート全文と、OcNOS-DC データシート全文です。
OcNOS-SP データシート
簡単なフォームです。送信後すぐに PDF が新しいタブで開きます。
✓ PDF を新しいタブで開いています…
開かない場合は、下記のリンクをご利用ください。
OcNOS-DC データシート
簡単なフォームです。送信後すぐに PDF が新しいタブで開きます。
✓ PDF を新しいタブで開いています…
開かない場合は、下記のリンクをご利用ください。