NETCONF, YANG 및 Zero-Touch Provisioning
OcNOS는 모델 기반 구성 인터페이스를 제공합니다. SSH/TLS 기반 NETCONF, OpenConfig 및 네이티브 YANG, commit/rollback을 지원하는 candidate 데이터스토어, 그리고 DHCP 임대로 새 라우터를 운영 상태까지 이끄는 Zero-Touch Provisioning입니다.
Day-0 Zero-Touch Provisioning 흐름
공장 출하 상태의 OcNOS 라우터가 부팅하여 DHCP 임대를 요청하고, 이미지를 가져온 다음 구성을 가져와 운영 상태에 도달합니다. 현장 운영자가 필요 없습니다.

모델 기반(model-driven) 구성이 중요한 이유
CLI 스크립트는 조합되지 않고, 롤백되지 않으며, 스키마에 따라 입력을 검증하지 않습니다. NETCONF + YANG 는 타입이 지정된 트랜잭션 방식의 구성 인터페이스를 제공합니다. candidate를 푸시하고, 검증한 뒤, 커밋하거나 어느 leaf라도 거부되면 변경 사항을 폐기합니다. OcNOS는 OcNOS 고유 파라미터를 위해 OpenConfig 모델과 IP Infusion 네이티브 모델을 제공합니다. Zero-Touch Provisioning과 결합하면 새 라우터가 현장 운영자 없이 운영 상태에 도달합니다.
OcNOS NETCONF, YANG 및 ZTP 구현
SSH + TLS 전송
RFC 6241 NETCONF 프로토콜, SSH (RFC 6242) 및 TLS (RFC 7589) 위에서 동작, Get / Get-Config / Edit-Config / Commit / Validate / Lock / Discard-Changes RPC 전체 지원.
후보 구성 + 커밋 / 롤백
NETCONF를 통한 candidate 데이터스토어. CLI에서는 commit confirmed와 커밋 이력의 이전 커밋으로의 commit-rollback.
Day-0 프로비저닝
IPv4 또는 IPv6 기반 DHCP 부팅: 이미지를 가져와 설치하고 재부팅한 다음 구성을 가져옵니다.
OcNOS 자동화로 얻을 수 있는 것
- 운영 롤백. 커밋 이력을 활성화하면, 변경 사항에 문제가 생길 때 CLI commit-rollback 명령으로 이전 커밋으로 돌아갈 수 있습니다.
자주 묻는 질문
OcNOS 는 NETCONF 를 통해 어떤 YANG 모델을 지원합니까?
OcNOS 는 구성 롤백을 지원합니까?
OcNOS에서 Zero-Touch Provisioning은 어떻게 동작합니까?
더 깊이 살펴보십시오. 자료를 소장하십시오.
이 페이지보다 한층 더 깊이 있는 간결한 기술 다운로드 자료 두 편: OcNOS-SP 데이터시트 전문과 OcNOS-DC 데이터시트 전문.
OcNOS-SP 데이터시트
간단한 양식입니다. 제출하면 PDF가 즉시 새 탭에서 열립니다.
✓ 새 탭에서 PDF를 여는 중입니다…
열리지 않았다면 아래 링크를 이용해 주십시오.
OcNOS-DC 데이터시트
간단한 양식입니다. 제출하면 PDF가 즉시 새 탭에서 열립니다.
✓ 새 탭에서 PDF를 여는 중입니다…
열리지 않았다면 아래 링크를 이용해 주십시오.

