IPv6 ソースルーティング・SRH 拡張ヘッダ

IPv6 上のセグメントルーティング

IPv6 データプレーンに適用された SR。セグメントリストを SRH 拡張ヘッダー内の IPv6 アドレスの並びとしてエンコードし、MPLS ラベルなしでソースルーティングを可能にします。

SRv6 SIDリストフォワーディング

パケットが 3 つの SR エンドポイントを通過します。

SRv6パケットフロー: IPv6 SIDリストfc00::1、fc00::2、fc00::3に従い3つのエンドポイントを通過
SRv6: IPv6 SIDリストに基づき3つのエンドポイントを通過するパケットの経路。

Segment Routingとは

Segment Routing(RFC 8402)はソースルーティングアーキテクチャ。ヘッドエンドはパケットが通る経路をセグメントと呼ばれる順序付き命令リストとしてエンコードし、ネットワークは各ホップでフローごとの状態を保持せずにそのリストに基づいて転送する。動作するデータプレーンは2つあり、SR-MPLSはセグメントリストをMPLSラベルスタックとして、SRv6はIPv6アドレスのリストとして運搬する。本ページではSRv6を扱い、SR-MPLSデータプレーンは別ページに記載。

SRv6 とは

SRv6(RFC 8986)は、特定ノードでのトポロジー命令(セグメント)を表す SID と呼ばれる IPv6 アドレスの順序付きリストとして、ソース主導のパスをエンコード。Segment Routing Header(SRH、RFC 8754)が IPv6 拡張ヘッダースタック内で SID リストを伝送。各 SR ノードで、アクティブな SID が処理され、SL(Segments Left)ポインタがデクリメントされ、IPv6 DA は次の SID に更新される。

SRv6 SID は、Locator(トポロジー的に意味のあるプレフィックス、通常 /48 または /64)と Function(動作識別子)で構成されるルーティング可能な IPv6 アドレス。これにより SR 転送状態が IPv6 ルーティングテーブルに埋め込まれ、別個のラベル空間、LFIB、MPLS 固有の HW リソースが不要。中継ノードは SR エンドポイントでない限り SRH 認識が不要。

SRv6 uSID(draft-ietf-spring-srv6-srh-compression)は SID のエンコードを圧縮します。複数のマイクロ SID を 1 つの 128 ビット IPv6 アドレスに詰め込むことで、SID リストが短くなり、長いエンジニアリングパスでのヘッダーオーバーヘッドを削減します。

SRv6 Network Programming

RFC 8986 は SRv6 エンドポイント動作のセットを定義:End(SR エンドポイント)、End.X(クロスコネクト付き)、End.T(テーブル参照付き)、End.DT4/DT6/DT46(デカプセル化と L3 テーブル参照)。これらの動作は SID セマンティクス内で VPN 転送機能を完全に実装し、純粋な IPv6 コア上で L3VPN および L2VPN サービスを実現。

OcNOS-SP の Segment Routing

OcNOS-SP は、26 台すべてのルーターで SR-MPLS を実行します。SRv6 のサポートは初期段階で、一部のルーターに限られ、今後さらに開発を進めています。

26 台すべてのルーターで SR-MPLS

IS-IS と OSPF のセグメントルーティング拡張、TI-LFA 高速再ルート、IS-IS Flex-Algo、SR Policy を、すべての OcNOS-SP ルーターで提供します。

IS-IS and OSPF for SRv6

IPv6 データプレーン上のセグメントルーティングのための IS-IS と OSPF 拡張。PLUS エディションを搭載した Qumran 2 ファミリーの 10 台のルーターで提供します。

SRv6 サービスの初期サポート

SRv6 上の BGP L3VPN(VPNv4)、EVPN E-LINE、シングルホームの EVPN E-LAN。RFC 9252 に従ってシグナリングします。

SRv6 OAM

同じルーターで RFC 9259 に準拠した SRv6 OAM。

SRv6 を初期サポートするルーター

参考用のみ。 SRv6 の初期サポートは、PLUS エディションを搭載した Qumran 2 ファミリーの OcNOS-SP ルーター 10 台で動作し、そのうち 7 台を以下に示します。現在のサポート状況はルーターとリリースごとに OcNOS Feature Matrix に掲載しています。

UfiSpace S9600-56DX
Qumran2c · 4×25G + 48×100G + 8×400G
UfiSpace S9600-28DX
Qumran2c · 4×25G + 24×100G + 4×400G
UfiSpace S9600-32X
Qumran2c · 32×100G
UfiSpace S9600-64X
Qumran2c · 64×100G
UfiSpace S9510-28DC
Qumran2a · 24×25G + 2×100G + 2×400G
Edgecore AS7535-28XB
Qumran2a · 24×25G + 2×100G + 2×400G
UfiSpace S9510-30XC
Qumran2u · 28×25G + 2×100G

よくあるご質問

SRv6 とは何ですか。
SRv6(Segment Routing over IPv6)は、IPv6 データプレーンを直接利用するセグメントルーティングです。各セグメントは SID と呼ばれる 128 ビットの IPv6 アドレスとしてエンコードされるため、ネットワークは MPLS ラベルスタックを用いることなく、ネイティブな IPv6 フォワーディングによって設計されたパスに沿ってトラフィックを誘導します。
SRv6 と SR-MPLS の違いは何ですか。
SRv6 はセグメントを 128 ビットの IPv6 アドレスとしてエンコードし、IPv6 データプレーン上でフォワーディングを行います。一方、SR-MPLS はセグメントを MPLS ラベルとしてエンコードし、MPLS データプレーン上でフォワーディングを行います。SRv6 はコアに IPv6 のみを必要とするのに対し、SR-MPLS は MPLS フォワーディングプレーンを維持します。
SRv6におけるuSIDとは何ですか。
uSID(micro-SID)は、複数の SRv6 命令を単一の 128 ビット IPv6 アドレスにまとめるため、1 つのアドレスで多数のセグメントを表現できます。これによりセグメントリストが短縮され、パケットのオーバーヘッドが削減され、より長い設計パスを標準の IPv6 フォワーディングの範囲内に収めることができます。
SRv6 に MPLS は必要ですか。
いいえ、SRv6にMPLSは不要です。SRv6はネイティブのIPv6データプレーン上で動作し、IPv6アドレスをセグメント識別子として使用するため、コアはIPv6のみで転送を行います。これにより、事業者はMPLSのラベルスイッチングプレーンを持たずにトラフィックエンジニアリングとサービスルーティングを運用できます。
SRv6におけるSRHとは何ですか。
SRH(Segment Routing Header)は、パケットが従うべきSIDの順序付きリストを運ぶIPv6拡張ヘッダーです。パケットがパスを通過する際、SRH内のアクティブなセグメントが次のホップを決定し、設計されたルートをIPv6パケット自体の内部にエンコードします。
SRv6とSR-MPLSのどちらを選ぶべきか
SRv6 は MPLS を使わず、ネイティブ IPv6 上でトラフィックエンジニアリングと VPN サービスを実行するため、IPv6 ファーストのネットワークやグリーンフィールドのネットワークに適しています。SR-MPLS は MPLS フォワーディングプレーンを維持するため、既存の MPLS 基盤を持ち、データプレーンを変えずにセグメントルーティングを導入したい事業者に適しています。
SRv6はL3VPNに対応するか
対応する。SRv6はRFC 8986で定義されるEnd.DT4・End.DT6・End.DT46のエンドポイント動作を用いてL3VPNを運び、これらはパケットをデカプセル化して対象のVRFで検索する。BGPはRFC 9252に従い、VPNごとのSIDをSRv6サービスとしてアドバタイズするため、VPNはMPLSサービスラベルを使わずに純粋なIPv6コア上で動作する。
OcNOS は SRv6 に対応していますか。
OcNOS-SP は、一部のルーターで SRv6 の初期サポートを備えており、今後さらに開発を進めています。PLUS エディションを搭載した Qumran 2 ファミリーの 10 台のルーターで、SRv6 上の BGP L3VPN、EVPN E-LINE、シングルホームの E-LAN サービス、SRv6 OAM、SRv6 向けの IS-IS と OSPF 拡張に対応します。26 台すべての OcNOS-SP ルーターでのセグメントルーティングには、OcNOS は TI-LFA 高速再ルートと IS-IS Flex-Algo を備えた SR-MPLS を実行します。

さらに詳しく。資料をお持ち帰りください。

製品データシートと、このページよりもさらに踏み込んだ簡潔で技術的なダウンロード資料です。

データシート

OcNOS-SP データシート

OcNOS-SP の完全な仕様。アクセス、セルサイト、アグリゲーションの機能セット、ソフトウェア SKU、サポート対象ハードウェアプラットフォーム、ソリューション発注ガイドを収録しています。

データシートを入手
ソリューションブリーフ

OcNOS による SR-MPLS アップグレード

オープンハードウェア上の OcNOS へ SR-MPLS を移行。Flex-Algo・TI-LFA と、ノード単位の移行パスを解説します。

概要資料を入手
ソリューションブリーフ

クラウド & サービスプロバイダー WAN 伝送

open hardware上でのクラウドおよびサービスプロバイダー向けWANトランスポート。SR-MPLS、EVPN、スケール検証済みのフォワーディングに対応します。

概要資料を入手

ルーターごとの SRv6 と SR-MPLS のサポートを確認

機能マトリクスを開く →