QoS:分類、監管、整形與排隊

服務品質(QoS)是指當鏈路上的流量超過鏈路容量時路由器所做的處理。OcNOS 在入口對流量進行分類,並按約定速率計量,然後在出口進行排隊、排程和整形,IP Infusion 提供的每個路由和交換平台都採用相同的配置模型。

QoS 流水線

資料包會經過兩次 QoS 處理。進入時,它被分類、可選地重新標記,並由監管器計量。離開時,它被放入佇列、由排程器選中,並通過整形器發出。每個階段都有各自的標準和各自的故障模式。

OcNOS 路由器上的 QoS 流水線 資料包從左到右經過六個階段。入口:按接口、ACL、DSCP、IP 優先級、RTP 或 802.1p 分類;標記或信任已有的 DSCP 和 802.1p 值;用單速率或雙速率三色計量器進行監管,可能丟棄或重新標記。出口:放入多個硬體佇列之一,佇列填充時應用 WRED;用加權輪詢、加權公平佇列或嚴格優先級在佇列間排程;通過按佇列或按埠的整形器發出。 入口 出口 分類 ACL / DSCP / 802.1p 標記 / 信任 RFC 2474 監管 srTCM / trTCM 排隊 WRED, RFC 2309 排程 WRR / WFQ / SP 整形 RFC 3644 丟棄或重新標記 緩衝區與時延 分類 · 標記 · 監管 · 排隊 · 排程 · 整形

監管和整形解決的是不同的問題

這兩者常被當作可以互換,但事實並非如此。監管器測量流量,並立即對當前的資料包採取動作。約定速率以內的流量通過,超出的流量被丟棄或重新標記為較低優先級,不做任何儲存。由於監管器從不緩衝區,它不會增加時延;也正因為它從不延遲,它無法平滑任何流量。突發會被截斷,而不是被吸收。

整形器正好相反。超出的流量被保存在佇列中,並按配置的速率發出,因此即使到達的流量是突發的,離開埠的流量也很平滑。這可以防止下遊鏈路或客戶交接點收到超過約定的流量,但平滑的代價是時延和緩衝區佔用。

實際的分工由此而來。 在入口監管,保護自己的網路免受超出所售頻寬的流量影響。 在出口整形,保護下遊的一切。 在出口交接點做監管,會讓應用遭遇無法預見的丟包。在入口做整形,只是把擁塞問題轉移到自己的緩衝區裡。

三種顏色,兩種測量方式

OcNOS 的兩種監管器都是三色標記器。綠色表示在承諾速率以內,黃色表示在突發容許量以內,紅色表示超出合約。區別在於速率的測量方式。單速率三色標記器(RFC 2697)基於一個速率,帶有承諾突發和超額突發,適合允許突發但不允許持續高速率的合約。雙速率三色標記器(RFC 4115)分別測量承諾速率和峰值速率,適合在承諾速率之上有明確硬上限的合約。兩者在全部 26 個服務提供商平台和 18 個資料中心平台上均可用。

OcNOS 實現了什麼

按實際存在的欄位匹配

按照 RFC 2475 的 DiffServ 架構,基於接口、訪問列表、DSCP、IP 優先級、RTP 或 802.1p 進行匹配。也可以將埠設置為信任上遊已設置的 802.1p 或 DSCP 值,而不重新分類。

srTCM 與 trTCM

符合 RFC 2697 的單速率三色計量和符合 RFC 4115 的雙速率三色計量,對超出合約的顏色執行丟棄或重新標記。在全部平台上可用。

溢出前啟用 WRED

符合 RFC 2309 的加權隨機早期檢測會隨著佇列增長丟棄越來越多的資料包,使發送端在尾部丟棄一次性衝擊所有流之前就降速。

WRR、WFQ 與嚴格優先級

每埠多個硬體佇列之間的加權輪詢、加權公平佇列和嚴格優先級排程,以 RFC 4594 的服務等級建議為起點。可以按佇列設置最小和最大頻寬。

按佇列和按埠

按照 RFC 3644 的策略模型,對單個佇列或整個埠應用速率整形,因此同一接口上可以同時存在總體上限和按類上限。

能回答問題的計數器

類映射統計和按出口佇列的計數器,可以證明策略匹配的正是你預期的流量,並證明佇列正在排空。

服務提供商平台與資料中心平台的差異

QoS 的大部分功能在兩類平台上通用,但有三項功能並非如此,若假定相同,就是一個應及早發現的設計錯誤。

  • 分層排隊是服務提供商平台的功能。 一級、二級或三級排隊層次(RFC 3644)讓埠級整形器位於各業務佇列之上,這正是電信業者乙太網交接點或企業業務匯聚埠所需要的。它在全部 26 個服務提供商平台上可用,不屬於資料中心平台集。相關的業務排隊模型(將業務映射到 VLAN 並對每個 VLAN 整形)適用範圍相同。
  • 顯式擁塞通知是資料中心平台的功能。 ECN(RFC 3168)以標記封包取代丟棄封包,讓端點得以做出反應,這正是無損 RDMA 傳輸得以運作的關鍵。在 AI 或儲存 fabric 上,它是 DCQCN 以及 PFC.
  • 橋接資料包的重新標記是資料中心平台的功能,在全部 18 個資料中心平台上可用。

如果設計依賴其中某項功能,請先確認平台。 功能矩陣 提供各平台的詳細資訊, 硬體相容性清單 則將其對應到執行這些功能的路由器和交換機。

正在為實際交接點制定 QoS 策略?

聯絡我們

常見問題

路由器上的 QoS 是什麼?
服務品質是路由器在鏈路繁忙時決定哪些資料包先轉發、哪些延遲、哪些丟棄的一組機制。在 OcNOS 上,它以流水線方式執行:對流量進行分類、標記,在入口按約定速率監管,然後在出口進行排隊、排程和整形。
流量監管和流量整形有什麼區別?
監管按速率測量流量並立即採取動作:超出速率的流量被丟棄或重新標記為較低優先級,不做任何儲存。整形將超出的流量保存在佇列中並按配置速率發出,因此流量被平滑而不是被截斷。監管保護網路,通常應用在入口。整形保護遠端,應用在出口,代價是增加時延和緩衝區佔用。
WRED 是什麼,為什麼要使用它?
加權隨機早期檢測會隨著佇列填充以逐漸增加的比例丟棄少量資料包,而不是等佇列溢出後一次性全部丟棄。按照 RFC 2309,這可以儘早向發送端發出擁塞信號,並防止各流同步陷入反覆的崩潰和恢復循環。OcNOS 在全部 26 個服務提供商平台和 18 個資料中心平台上支援 WRED。
srTCM 和 trTCM 是什麼?
它們是用於監管的兩種標準三色計量方案。單速率三色標記器(RFC 2697)測量一個速率,帶有承諾突發和超額突發,將流量標記為綠、黃或紅。雙速率三色標記器(RFC 4115)分別測量承諾速率和峰值速率。OcNOS 同時實現了這兩種方案,因此監管器既可以針對一個速率允許突發,也可以強制執行獨立的峰值上限。
OcNOS 支援分層 QoS 嗎?
支援,在服務提供商平台上。OcNOS 支援一級、二級或三級排隊層次(RFC 3644),因此埠總體整形器可以位於按業務或按客戶的佇列之上。分層排隊和相關的按業務排隊模型是服務提供商功能,不屬於資料中心平台集。
OcNOS 可以根據什麼對流量進行分類?
按照 RFC 2475 的 DiffServ 架構,分類可以匹配入接口、訪問列表、DSCP、IP 優先級、RTP 或 802.1p 優先級位。還可以讓路由器信任鄰居已設置的 802.1p 或 DSCP 值,避免對已在網路邊緣正確標記的流量重新分類。